Frequently Asked Questions

USPS Shipping Rates Not Calculating
Last Updated a year ago

If you use USPS to calculate your shipping rates in Cart32 inside of Cart32, they may stop working if your web server is not set up correctly. USPS is updating the security on their servers, which means some older web servers will not be able to contact USPS to get rates in the near future.

If you are hosting your shopping cart directly with Cart32, then this will not be an issue. If you are hosting with a reseller, you should check with them to see if their servers are updated to support a technology called TLS 1.2.

If you have any other questions, please don't hesitate to contact us at support@cart32.com and we will be happy to help you in anyway that we can.

Information Provided By USPS
This message explains some security improvements planned for our services. Effective 06/22/18, Web Tools will discontinue support of Transport Layer Security (TLS) version 1.0 and 1.1 for securing connections to our HTTPS APIs through the following URL: https://secure.shippingapis.com/shippingapi.dll. This includes, but is not limited to, all shipping label and package pickup APIs. After this change, integrations leveraging TLS version 1.0 and 1.1 will fail when attempting to access the APIs. Integrators are encouraged to update to at least TLS 1.2 to avoid connection issues.

In advance of the changes to production, TLS version 1.0 and 1.1 support will be discontinued in the lower Web Tools environments and available for testing on 5/22/18: https://stg-secure.shippingapis.com/shippingapi.dll).

Further Background
Security research published in recent years demonstrated that TLS version 1.0 and 1.1 contained weaknesses that limited its ability to protect and secure communications. These weaknesses have been addressed in the TLS 1.2 version. Major browser software vendors have been supporting TLS 1.2 for some time. Consistent with our priority to protect USPS Web Tools customers, Web Tools will only support versions of the more modern TLS 1.2 as of the effective date noted above.

Contact
Contact us at webtools@usps.gov with any questions or concerns regarding TLS changes. If you experience issues with your Cart32 installation, please verify you are on the latest version of the cart system and have updated your server to only allow TLS 1.2 connections.

Please Wait!

Please wait... it will take a second!